Issue
Archive Shuttle 6.7 and higher can optionally use EWS where MAPI was required before (e.g. Shortcut Process).
The Archive Shuttle Shortcut Process Module EWS may log “ProcessFolder|[user@xxx.com] type:[Archive]: Start searching with filter” twice.
It might look that there are two threads, searching the same folder. See below:
 

1)
 2015-05-13 12:16:49Z|6000| 66|DEBUG|                                     ProcessFolder|[user@xxxx.com]: Search starting in folder [\Inbox\2010]  
 2015-05-13 12:16:49Z|6000| 66|TRACE|                                     ProcessFolder|[user@xxxx.com] type:[Archive]: Start searching with filter [ArchiveShuttle.Module.ShortcutPostprocessModule.EWS.EnterpriseVault.MessageClassShortcutFilter
 2015-05-13 12:16:49Z|6000| 66|TRACE|                                  SearchAndProcess|Searching for items in [user@xxxx.com][\Inbox\2010], folder id 

 

2)
 2015-05-13 12:17:41Z|6000| 71|TRACE|                                     ProcessFolder|[user@xxxx.com] type:[Archive]: Start searching with filter [ArchiveShuttle.Module.ShortcutPostprocessModule.EWS.EnterpriseVault.MessageClassShortcutFilterExtended
 2015-05-13 12:17:41Z|6000| 71|TRACE|                                  SearchAndProcess|Searching for items in [user@xxxx.com][\Inbox\2010], folder id [AAMkADczNjRiNjMzLTQ5NzEtNGMwNS1iYTQyLTYxNmJmYmJiZjM4OQAuAAAAAAA4wPZniBrZTqNN9t7mnfWSAQDlH3BgHy7lQJ11YW4yNbyrAAAXZ9C6AAA=] 
 

 
Solution
This behavior is by design.
The first pass is searching purely for Message Class, ie traditional Enterprise Vault shortcuts.
The second pass is searching for the SSID/ArchiveID Properties.

Print Friendly, PDF & Email