1. Home
  2. Archive Shuttle
  3. INFO: EV export settting “Error message(s) to permanently fail items on”

INFO: EV export settting “Error message(s) to permanently fail items on”

Summary

This article explains how to check whether errors are set to permanently failed using EV export setting to set item as permanently failed after 1st attempt.

Details

You can verify errors are really permanently failing after 1st attempt in EV export core logs looking for “HandlePermanentErrors” + SQL itemrouting table check for permanently failed items.

In this example used error “Enterprise Vault is not running.”

See log:

2019-09-09 08:39:20Z| 7580| 74|TRACE| ProcessErrors|Processing error for ItemRouting [1091102] with error [Enterprise Vault is not running.].
2019-09-09 08:39:20Z| 7580| 74|TRACE| ProcessErrors|Processing error for ItemRouting [1091103] with error [Enterprise Vault is not running.].
2019-09-09 08:39:20Z| 7580| 74|TRACE| ProcessErrors|Processing error for ItemRouting [1091104] with error [Enterprise Vault is not running.].
2019-09-09 08:39:20Z| 7580| 74|TRACE| ProcessErrors|Processing error for ItemRouting [1091105] with error [Enterprise Vault is not running.].
2019-09-09 08:39:20Z| 7580| 74|DEBUG| ProcessErrors|Committed updates of failed items to ItemRouting table [524 ms]
2019-09-09 08:39:20Z| 7580| 74|DEBUG| HandlePermanentErrors|Marking [284] item(s) as permanently failed because of enabled EVExport module setting [Fail items permanently on specified errors]. Error message contains: [enterprise vault is not running.]

Details

1. ProcessErrors – with an error you set, in my case “Enterprise Vault is not running.”

2019-09-09 08:39:20Z| 7580| 74|TRACE| ProcessErrors|Processing error for ItemRouting [1091102] with error [Enterprise Vault is not running.].
2019-09-09 08:39:20Z| 7580| 74|TRACE| ProcessErrors|Processing error for ItemRouting [1091103] with error [Enterprise Vault is not running.].
2019-09-09 08:39:20Z| 7580| 74|TRACE| ProcessErrors|Processing error for ItemRouting [1091104] with error [Enterprise Vault is not running.].
2019-09-09 08:39:20Z| 7580| 74|TRACE| ProcessErrors|Processing error for ItemRouting [1091105] with error [Enterprise Vault is not running.].
2019-09-09 08:39:20Z| 7580| 74|DEBUG| ProcessErrors|Committed updates of failed items to ItemRouting table [524 ms]

2. HandlePermanentErrors – how many items were set as permanently failed

2019-09-09 08:39:20Z| 7580| 74|DEBUG| HandlePermanentErrors|Marking [284] item(s) as permanently failed because of enabled EVExport module setting [Fail items permanently on specified errors]. Error message contains: [enterprise vault is not running.]

3. Check SQL for random ItemRouting ids to confirm those are really set as permanently failed

SELECT * FROM [item database].[dbo].[ItemRouting]
where IsExportFailed = 1 and IsExportFailedPermanently = 1 and ItemRoutingId = “item routing id from step 1”

 

Print Friendly, PDF & Email
Updated on September 9, 2019

Was this article helpful?

Related Articles