Issue
You might encounter a situation where you need to switch your migration back to online mode in order to complete migration for some archives. You may have disabled Offline Media setting using the AS Links page, items are exporting to your Staging Area, but you may notice that the import process is failing with following error:

2016-02-19 12:27:42Z|1382| 13|ERROR| ProcessCopy|Error in copy thread. Void WinIOError(Int32, System.String)
The network name cannot be found.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileInfo.get_Length()
at ArchiveShuttle.Module.EVImportModule.CopyManager.Process(ICopyProvider copyProvider, EVImportItemContainer importItem)
at ArchiveShuttle.Module.EVImportModule.WorkManager.ProcessCopy(EVImportItemContainer importItem)

Solution
We recommend you check the items below.

  • Is the staging area set correctly?
  • Was Offline Mode disabled for the correct source and target link?
  • Check mappings via AS Existing Mappings page. If there is not a green and white checkmark shown in the Link Offline Mode or Container Mapping Offline Mode columns, the columns need to be added using the Column Chooser.

If you’ve checked all of the items above, we suggest you check the column OfflineMediaImportPathId in the table [ItemRouting] in Archive Shuttle Item database. The following SQL query can be used:
SELECT * FROM [ItemRouting] where ContainerMappingId = xxx
The column OfflineMediaImportPathId should be set to NULL. If it’s not, change it so it’s set it to NULL. It may not be set to null if there were items that were temporary failures during export while in Offline Media-mode, and these are being re-tried, which lead to the error being logged in the log file.
If the import doesn’t start immediately, retry Failed Imports for the appropriate mappings.

Print Friendly, PDF & Email