Issue
After Export, the import doesn’t start.
Example from Core log file with Trace loggin turned on.
[2014-02-06 09:54:48Z] [ 2588] [   62] [TRACE] [GetEVImport] Retrieving Import items for ContainerMapping: 2
[2014-02-06 09:54:48Z] [ 2588] [   16] [TRACE] [GetReadyContainerMappingsByCommandId] Got 0 containers.
[2014-02-06 09:54:48Z] [ 2588] [   16] [TRACE] [GetReadyContainerMappingsByCommandId] Retrieving Ready Container Mappings for Command: FixShortcuts | Module: cd611cb0-cd8c-e311-9425-005056b83d91 | SourceContainer: False
[2014-02-06 09:54:48Z] [ 2588] [   16] [TRACE] [GetReadyContainerMappings] Module ID: cd611cb0-cd8c-e311-9425-005056b83d91 | IsSourceContainer: False | WorkflowSequenceId: 38 | PreviousWorkflowSequenceId: 55 | WorkflowTriggerId: -1 | Count: 10 | RetryFailed: True | RetryFailedAfterMinutes: 60 | RetryUnresponsive: True | RetryUnresponsiveAfterMinutes 30
[2014-02-06 09:54:48Z] [ 2588] [   16] [TRACE] [GetReadyContainerMappingsByCommandId] Got 0 containers.
[2014-02-06 09:54:48Z] [ 2588] [   16] [TRACE] [GetReadyContainerMappingsByCommandId] Returning 0 containers.
[2014-02-06 09:54:48Z] [ 2588] [   16] [TRACE] [GetByTrigger] GetByTrigger: triggerDefinition: ArchiveShuttle.Core.Library.Workflow.WorkflowTriggerDefinitionEnum[], commandNotProcessed: DeleteShortcuts, moduleId: cd611cb0-cd8c-e311-9425-005056b83d91, policies: 0, count: 10, useSourceContainer: True
[2014-02-06 09:54:48Z] [ 2588] [   62] [TRACE] [GetToImportForMapping] Got 0 items to import.
[2014-02-06 09:54:48Z] [ 2588] [   62] [TRACE] [GetEVImport] Got 0 items eligible for importing. Are all your retention categories properly mapped?
[2014-02-06 09:54:48Z] [ 2588] [   62] [TRACE] [GetEVImport] Retrieving Import items for ContainerMapping: 3
[2014-02-06 09:54:48Z] [ 2588] [   16] [TRACE] [GetByTrigger] GetByTrigger: triggerDefinition: ArchiveShuttle.Core.Library.Workflow.WorkflowTriggerDefinitionEnum[], commandNotProcessed: DeleteShortcuts, moduleId: cd611cb0-cd8c-e311-9425-005056b83d91, policies: 0, count: 10, useSourceContainer: False
[2014-02-06 09:54:48Z] [ 2588] [   16] [TRACE] [GetReadyContainerMappingsByCommandId] Retrieving Ready Container Mappings for Command: DeleteShortcuts | Module: cd611cb0-cd8c-e311-9425-005056b83d91 | SourceContainer: False
[2014-02-06 09:54:48Z] [ 2588] [   16] [TRACE] [GetReadyContainerMappings] Module ID: cd611cb0-cd8c-e311-9425-005056b83d91 | IsSourceContainer: False | WorkflowSequenceId: 60 | PreviousWorkflowSequenceId: 59 | WorkflowTriggerId: -1 | Count: 10 | RetryFailed: True | RetryFailedAfterMinutes: 60 | RetryUnresponsive: True | RetryUnresponsiveAfterMinutes 30
[2014-02-06 09:54:48Z] [ 2588] [   62] [TRACE] [GetToImportForMapping] Got 0 items to import.
[2014-02-06 09:54:48Z] [ 2588] [   62] [TRACE] [GetEVImport] Got 0 items eligible for importing. Are all your retention categories properly mapped?
[2014-02-06 09:54:48Z] [ 2588] [   62] [TRACE] [Dispose] << Retrieving Items for Container Mappings [16.7538 ms]

[2014-02-06 09:54:48Z] [ 2588] [   62] [TRACE] [GetEVImport] Got 2 commands with 0 items to import.

This is caused by non-mapped retention categories.
Solution
Run this query on the appropriate ITEM database and modify the Container mapping ID as required, it will show which Retention category is currently mapped to the selected container:

SELECT iev.itemid, iev.haslegalhold, iev.archiveddateutc, iev.sourceretentioncategoryid, asdbr.name
FROM itemrouting ir, itementerprisevault iev,  [ArchiveShuttleDirectory].[dbo].[EVRetentionCategory] asdbr, EVRetentionCategory EVR
WHERE ir.itemid = iev.itemid and
             iev.sourceretentioncategoryid = EVR.RetentionCategoryID and
             EVR.RetentionCategoryEVId = asdbr.EVRetentionCategoryID and
             ir.containermappingid = 1

There are two possibilities to do:
– Delete mapping, create new archives and make sure it get enabled and contain archived data from the right retention category
– Add another retention category mapping

Print Friendly, PDF & Email