Issue
When extracting data from an Enterprise Vault journal archive, the following may be logged in the EV Export Module log file:
2013-12-09 08:35:55Z|ERROR|P:4556|T:10|ItemExport|Error occured. ArchiveID: [1271E06D8C1C5504EAF16A3DF86E4D2DF1110000vault] | ItemID: [dd2fece4-ecae-425d-b01a-144c0b0173d0]
EXCEPTION: System.Exception: Original message id not found in index.
at ArchiveShuttle.Module.EVExportModule.Envelope.GetEnvelope(ISimpleIndexMetadata index, String& originalMessageId)
at ArchiveShuttle.Module.EVExportModule.Envelope.Reconstruct(IArchiveMetaData cmMetaData, String messageFileName)
at ArchiveShuttle.Module.EVExportModule.ItemExport.ExportItem(EVExportResult item, Boolean useEnvelope)

Solution
The Message ID MAPI property is used to help reconstruct the P1 envelope. Without it Archive Shuttle can not perform this action, therefore the item is marked as failed.
The first step to perform is to do an Advanced Search using Enterprise Vault of the journal archive.  Add the ‘Other Result Attributes’ SSID and IDEN and perform some general searches to confirm that the items do have a message ID.  Now search for the specific Transaction ID (Item ID) listed in the log file.  The IDEN field will be empty which confirms that it is in fact missing.
These items will also be visible on the Failed Items screen. There are three possible way to proceed:
a/ Enable “Export Messages with invalid Message ID from Journal” setting on System Configuration screen
b/ Increment the Failed Items threshold, and ignore these problems items
c/ Use the Failed Items page download the message, which will present it without the P1 envelope reconstruction, and then increment the Failed Items Threshold and move on with the Stage 1 and Stage 2 operations.
Note: Envelope reconstruction is not used with Enterprise Vault 10.0.4 or later.

Print Friendly, PDF & Email