Issue
Several modules in Archive Shuttle make use of the Enterprise Vault API, and also integrated in to the Enterprise Vault Extensions framework. This framework is provided by Enterprise Vault 10.0.4 and later, therefore the module needs to check whether that version of the API is installed or not.
If the API is not installed, or is lower than the 10.0.4 the following may be seen when the module/service starts:

2014-04-07 06:36:41Z|DEBUG|P:3508|T:5|Logic|EVExport Module Registred. Service GUID is 9fx0385a-b98c-e311-b5e2-00c29897fa7
2014-04-07 06:36:41Z|DEBUG|P:3508|T:5|ExtensionContentProvider|
Invalid Cast Exception. Most likely EV Version is < 10.0.4 or the API is not installed.
EXCEPTION: System.InvalidCastException: Unable to cast COM object of type 'KVS.EnterpriseVault.Interop.ContentManagementAPIClass' to interface
type 'KVS.EnterpriseVault.Interop.IContentManagementAPI6'.
This operation failed because the QueryInterface call on the COM component for the
interface with IID '{54DE8640-2B41-47B2-BCF1-AB85BD6A64A5}'
failed due to the following error:
No such interface supported (Exception from
HRESULT: 0x80004002 (E_NOINTERFACE)).
at KVS.EnterpriseVault.Interop.ContentManagementAPIClass.get_DirectoryDNSAlias()
at ArchiveShuttle.Module.EVContentProvider.ExtensionContentProvider.CheckContentProviderAPIAvailability(String& errorMessage)
2014-04-07 06:36:41Z|ERROR|P:3508|T:5|ExtensionProvider|Error while setting content provider: Invalid Cast Exception. Most likely EV Version is < 10.0.4 or the API is not installed.
2014-04-07 06:36:41Z|DEBUG|P:3508|T:5|Logic|EV Extension not registered. See previous errors.

 
This will appear on the following modules:
– EV Export Module
– EV Import Module
– EV Collector Module
– EV Provisioning Module
– EV Post Processing Module
 
Solution
This is a normal “error” and can be ignored.

Print Friendly, PDF & Email